Jaime Neto | desenvolvimento para web

mar/12

20

Iniciando o WAMP junto com o Windows


Se você trabalha com WAMP, sabe como é chato toda vez que iniciar o Windows ter que iniciá-lo para que possa usar o Apache e o Mysql. Então, vai uma dica rápida para iniciar esses serviços junto com o Windows, que não é apenas copiar o link de inicialização do WAMP para a pasta “Inicializar” (que nem sempre funciona, ou fica exibindo aquela tela de permissão).

Eis o passo a passo:

  1. No Windows 7, clique em Iniciar e, na barra de pesquisa por programas e arquivos, digite: services.msc
  2. Clique no arquivo que vai aparecer, ou simplesmente aperte o ENTER.
  3. Na janela que se abre, procure os serviços de nome: wampapache e wampmysqld
  4. Perceba que na coluna “Tipo de Inicialização”, eles estão como “Manual”
  5. Clique com botão direito em um deles, e selecione “Propriedades”
  6. Mude “Tipo de Inicialização” para “Automático” e clique “OK”
  7. Faça o mesmo para o outro serviço.

Prontinho… quando você reiniciar o Windows os serviços já estarão inicializados. Perceba, no entanto, que o que estará sendo iniciado automaticamente são os serviços Apache e Mysql, e não o Wamp em si. Ou seja, o iconezinho dele não vai estar lá do lado do relógio. Mas você vai poder usar os serviços normalmente, e só se realmente precisar mexer no WAMP é que vai ter que iniciá-lo.

Repare que essa dica serve pra o caso de você querer inicializar automaticamente qualquer desses outros serviços da lista. Prático, não? ^__^

· ·

9 comments

  • Breno Mol · 17 de outubro de 2012 às 13:03

    Muito bom cara, funcionou legal. abraço

    Responder

  • Filipe · 28 de novembro de 2012 às 21:40

    Obrigadoo!

    Responder

  • Will Santos · 6 de janeiro de 2013 às 12:50

    funcionou certinho!!!!!!!!!!1

    Responder

  • Denis Alustau · 12 de abril de 2014 às 22:35

    Showw! Se garantiuu

    Responder

  • Geison · 5 de setembro de 2015 às 9:29

    Dica excelente, salvou a pele da turma!

    Responder

  • Felipe · 20 de julho de 2016 às 8:46

    Iniciou certinho, porem o local host não funciona, tem como deixar o WAMP SERVER configurado para subir junto com o WINDOWS?

    Responder

    • Admin comment by jaime · 14 de setembro de 2016 às 8:36

      A ideia do post é justamente pra que inicie junto com o Windows. Se não está funcionando o localhost, talvez tenha alguma configuração adicional faltando…

      Responder

  • Carla Souza · 15 de janeiro de 2017 às 11:30

    Me ajudou muito. Obrigada!

    Responder

  • Roberto · 30 de janeiro de 2017 às 10:10

    Oi Jaime, fiz a configuração de acordo com a sua orientação, só que o WAMPSERVER continua parado, e ele somente starta manualmente se eu der um comando no prompt do administrador.

    c:\WINDOWS\system32> net stop WAS

    O que mais poderia fazer pra resolver?

    Abraço!

    Responder

Leave a Reply

<<

>>

Theme Design by devolux.nh2.me